Dirty Ol' BC Forums: 95 bg5 surging or misfiring - Dirty Ol' BC Forums

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

95 bg5 surging or misfiring

#1 User is offline   Slavit 

  • n00b
  • Group: Members
  • Posts: 7
  • Joined: 21-September 18
  • Location:South waikato
  • Vehicles:
    • 1995 legacy

Posted 26 September 2018 - 10:04 PM

Hey everyone i have been dealing with this problem since i had someone pull the engine out to do the cam crank seal and other seals. It started off a slow. Would slowly jerk in fifth when heavy on the pedal. Then it started doing it in fourth. Then third. Well i think you get the picture. I can barely leave an intersection without it kicking a massive fuss jerking and surging all over the place. I've done the afm. Swapped the arc airfilter to the stock air box. Check coil packs and all appear to be fine, visually. Vacuum hoses all appear to be in the right places. I have some different coils that i should try re wire to fit. But i really dont think it is a firing problem. Maybe fueling? I have another fuel pump to try. Anyone else have a suggestion or better yet, anyone close to the south waikato wants to take my car for a drive and try diagnose it? Can sus you out something. Cheers fullas.
0

#2 User is offline   Slavit 

  • n00b
  • Group: Members
  • Posts: 7
  • Joined: 21-September 18
  • Location:South waikato
  • Vehicles:
    • 1995 legacy

Posted 26 September 2018 - 10:46 PM

Just run the diagnostics and i got a code 32 and code 13. O2 sensor and cam angle sensor. Will try find some replacements.
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users