Jump to content


Photo

Rs missing lurching


  • Please log in to reply
1 reply to this topic

#1 calbaru

calbaru

    Auto Driver

  • Members
  • 54 posts
  • Location:wanaka
  • Vehicles:
    • 87 XX leone
      89 Rs
      89 BF 'madness'

Posted 24 May 2017 - 3:08 AM

hello folks
having a few issues with Rs
cat light came on a while back.
would be intermittent usually go off after a while
one night giving the car a bit of a thrash it started lurching and missing under boost
changed plugs new platinum thanks reuben
second hand o2 sensor which supposedly was fine
car started straight up
idling not smooth
cat light on continuously
it has a turbo back 2 1/2 or 3 inch straight pipe with no sensor in it that i can see
sounded like it was hunting but running rich smelling
sitting above 1000 rpm then dropping below and back up to 1300ish
took it for a wee drive it had been sitting for a couple of months
lurchy like it was fuel starved or cold even though i let it warm up properly
pulled over and idling nice 750 rpm
started 5 min later back to erratci idle and driving up drive lurchy

any ideas?

#2 Sammy

Sammy

    Boosted!

  • Members
  • 651 posts
  • Location:Christchurch
  • Vehicles:
    • 1991 GTS2 legacy sedan (project)
      1995 2 door gc1 - Retna Impreza

Posted 25 May 2017 - 6:32 AM

Have you checked the codes?

Loose wire/plug somewhere on something you just played with?

The cat light thing doesn't sound to healthy lol. How old is the exhaust system? I think they run on a temp sensor but someone here can confirm that. Have heard of flexis/cats collapsing and causing exhaust restriction problems(not had cat light on any car myself).

Idle problem could be related or something else. It's hard to say, check codes and go from there.
Posted Image




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users